Skip to end of metadata
Go to start of metadata

Preconditions for supported Database Management Systems

The following preconditions have to be met to allow JobScheduler to work with a Database Management System (DBMS):

  • JobScheduler database connections are made using JDBC and therefore a JDBC driver for that DBMS is required.
    • Not all JDBC drivers are compatible with our Open Source License and cannot be provided with the JobScheduler distribution.
    • Therefore users should download the respective JDBC drivers from the DBMS vendor web site.
  • The JobScheduler installer provides a script for the DBMS that creates the required database objects, e.g. tables, indices.
  • The JobScheduler has been tested to be compatible with the respective release of the DBMS.

DBMS Compatibility Matrix

History of JobScheduler Releases and DBMS Compatibility

The following terms are used in the matrix:

  • Confirmed as compatible: SOS has performed successful tests with the respective DBMS version.
  • Unconfirmed compatibility: we have knowledge of successful use with this DBMS version. However we did not test JobScheduler with this DBMS release.
  • Recommended JDBC Driver: SOS has performed successful tests with the respective JDBC Driver. Other versions and other JDBC Drivers may work.


DBMSVersions confirmed as
compatible with JobScheduler
Versions with
unconfirmed compatibility
Recommended JDBC
Driver Version
JDBC Driver provided
with JobScheduler
Comments

Oracle®

8.1.7, 9.2, 10g, 11g, 12c, 18c19c11.1.0.7.0-Productionojdbc6.jar

Newer JDBC Driver versions can be downloaded individually:

  • 12.1.0.2.0: ojdbc7.jar
  • 12.2.0.1.0: ojdbc8.jar

New DBMS versions are are added to our test environment after availability of XE releases 

SQL Server®2008. 2012, 20172000, 2005, 20141.3.1jtds-1.3.1.jar

jTDS is not supported by its authors.
We recommend to download the Microsoft JDBC Driver:

  • 6: sqljdbc42.jar
  • 7: comes for Java 8 and 10
    • mssql-jdbc-7.0.0.jre8.jar
    • mssql-jdbc-7.0.0.jre10.jar


JS-1707 - Getting issue details... STATUS

DB2®8.x
(for releases up to 1.10)
10.5
(for releases up to 1.10)
1.3.1db2jcc.jarDB2 is not supported starting from release 1.11
MariaDB®-10.0.14

1.10: mariadb-java-client-1.1.7.jar

1.11, 1.12: mariadb-java-client-1.3.0.jar

1.12.6: mariadb-java-client-2.2.6.jar

MariaDB Driver 1.3.0 can be used starting from release 1.10 

MariaDB Driver 2.2.6 can be used starting from release 1.12 

MySQL®5.5, 5.6, 5.7, 8.0 (for releases starting from 1.12.6) 

2.2.6

1.10: mariadb-java-client-1.1.7.jar

1.11, 1.12: mariadb-java-client-1.3.0.jar

1.12.6: mariadb-java-client-2.2.6.jar

MariaDB Driver 1.3.0 can be used starting from release 1.10

MariaDB Driver 2.2.6 can be used starting from release 1.12.6

JS-1799 - Getting issue details... STATUS

Alternatively use the MySQL JDBC Driver (required for use with MySQL 8)

PostgreSQL®8.x, 9.1, 9.2, 9.3, 9.4, 9.5, 9.6,10.5, 11.2
9.4

1.10: postgresql-9.4-1201-jdbc4

1.11: postgresql-9.4.1209.jar

JDBC Driver 9.4.1209 can be used starting from release 1.10
Sybase ASE®ASE 15.0
(for releases up to 1.10)
16.0
(for releases up to 1.10)
1.3.1jtds-1.3.1.jar

Alternatively use the Sybase JDBC Driver

Sybase is not supported starting from release 1.11

DBMS Compatibility Test Results

Loading


Loading

Explanations:

  • The above report is the result of automated compatibility testing and is updated on a per JobScheduler release.
  • At the time of General Availability for JobScheduler Release 1.12.9 no JDBC Driver product compatible with Java 12 is available.
  • Do not use JDBC Drivers marked as incompatible (orange color).
  • Use of JDBC Drivers with limited compatibility (yellow color) results in warnings that you will find in the JobScheduler log files.

See also



  • No labels