Skip to end of metadata
Go to start of metadata

Features

The following new features have been included with the 64-bit JobScheduler:

  • the method of handling of JavaScript has been improved JS-982 - Different handling of javascript in 64bit JobScheduler Resolved
  • different time zones can now be specified per job and order JS-983 - Different time zones per job and order Resolved
  • JobScheduler now handles XML via Java instead of the C++ implementation of libxml2 JS-984 - JobScheduler should handle xml via Java instead the C++ implementation of libxml2 Resolved

Job Compatibility

The following JITL - JobScheduler Integrated Template Library jobs will not work with the 64-bit JobScheduler:

  • Extract
  • Managed Custom Reports

These jobs have been marked as deprecated but will be supported in the 32-bit versions of JobScheduler 1.7.x.
They will not be supported in JobScheduler releases starting from 1.8.

Feedback

Should you have problems with the installation and/or discover reproducible bugs that are not yet documented (see our bug tracker) or if the 64-bit JobScheduler works perfectly for you then please let us know at:

  • [betatest] @ [sos-berlin.com] 

Don't forget to include:

  • details of your environment incl. configuration files,
  • copies of the scripts you were running,
  • relevant log files.

Installation

Installation of the 64-bit JobScheduler is almost identical to that of the 32-bit Version, which is described in our JobScheduler Master - Installation Guide.

The following additional requirements apply for the 64-bit version:

64-Bit Requirements

The 64-bit Beta version requires the following:

  • Oracle™ Java Runtime Environment (JRE) 64-bit: at least version 1.6.x
  • A shell in /bin/sh (or a symlink)
  • The following 64-bit libraries:
    • linux-vdso.so.1
    • libz.so.1
    • libpthread.so.0
    • libdl.so.2
    • libm.so.6
    • libc.so.6
    • ld-linux-x86-64.so.2
      In addition, two components (JOE (JobScheduler Object Editor) and JID (JobScheduler Information Dashboard)) of the JobScheduler are SWT applications and require an X Windows system and GTK2. The JobScheduler installation includes a 64-bit swt.jar but you still need the following 64-bit libraries:
  • libgtk-x11-2.0.so.0
  • libXtst.so.6

Finally, we recommend that before starting the installation you set the JAVA_HOME environment variable to your 64-bit Java version (see “Requirements”, above).