Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

DBMSVersions confirmed as
compatible with JobScheduler
Versions with
unconfirmed compatibility
Recommended JDBC
Driver Version
JDBC Driver provided
with JobScheduler
Comments

Oracle®

8.1.7, 9.2, 10g, 11g, 12cn/a11.1.0.7.0-Productionojdbc6.jar 
SQL Server®2000, 2005, 2008. 201220141.3.1jtds-1.3.1.jar

Alternatively use the Microsoft JDBC Driver

JIRA
columnskey,summary,type,created,updated,due,assignee,reporter,priority,status,resolution
serverSOS JIRA
serverId6dc67751-9d67-34cd-985b-194a8cdc9602
keyJS-1707

DB2®8.x
(for releases up to 1.10)
10.5
(for releases up to 1.10)
1.3.1db2jcc.jarDB2 is not supported starting from release 1.11
MariaDB®-10.0.14 

1.10: mariadb-java-client-1.1.7.jar

1.11, 1.12: mariadb-java-client-1.3.0.jar

1.12.6: mariadb-java-client-2.2.6.jar

MariaDB Driver 1.3.0 can be used starting from release 1.10 

MariaDB Driver 2.2.6 can be used starting from release 1.12 

MySQL®5.5, 5.6, 5.78
(for releases starting from 1.12.6) 
2.2.6

1.10: mariadb-java-client-1.1.7.jar

1.11, 1.12: mariadb-java-client-1.3.0.jar

1.12.6: mariadb-java-client-2.2.6.jar

MariaDB Driver 1.3.0 can be used starting from release 1.10

MariaDB Driver 2.2.6 can be used starting from release 1.12.6

JIRA
columnskey,summary,type,created,updated,due,assignee,reporter,priority,status,resolution
serverSOS JIRA
serverId6dc67751-9d67-34cd-985b-194a8cdc9602
keyJS-1799

Alternatively use the MySQL JDBC Driver (required for use with MySQL 8)

PostgreSQL®8.x, 9.1, 9.2, 9.3, 9.4, 9.5, 9.6,10.5 9.4

1.10: postgresql-9.4-1201-jdbc4

1.11: postgresql-9.4.1209.jar

JDBC Driver 9.4.1209 can be used starting from release 1.10
Sybase ASE®ASE 15.0
(for releases up to 1.10)
16.0
(for releases up to 1.10)
1.3.1jtds-1.3.1.jar

Alternatively use the Sybase JDBC Driver

Sybase is not supported starting from release 1.11

...