Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

JobScheduler Java Release Policies

  • Since Java 1. 9 Oracle® changed the JVM life cycle:
    • New Java feature releases ship every 6 months.
    • Public maintenance for Java feature releases is restricted to 6 months. Users can opt for a support contract with Oracle® to prolong maintenance for Java.
    • Java releases do not follow semantic versioning.
  • These changes affect JobScheduler releases as follows:
    • We cannot know in advance if new Java releases will or will not be compatible with existing JobScheduler releases. Compatibility testing requires substantial effort and is partly performed by the JobScheduler community, see below explanations on Supported Compatibility 1) and Reported Compatibility 2).
    • JobScheduler Agents are available for a larger number of platforms, including AIX®, HP-UX® etc. Such platforms tend to implement new JVM releases with some substantial delay. 
  • SOS Release Policies
    • All JobScheduler components (Master, Agent, JOC Cockpit) are built with the same Java release.
    • JobScheduler components are not built with the newest Java release but with the oldest compatible Java release, e.g. JobScheduler 1.12 is built with Java 1.8, JobScheduler 2.0 is built with Java 1. 10.
    • We try to consider compatibility with newer Java feature releases, e.g. a JobScheduler Master 1.12.2 is built with Java 1.8 and can be operated with Java 1.8, 1. 9 and 1. 10 that are supported Java releases at the time of public availability of the JobScheduler Master. We do not guarantee compatibility with upcoming Java feature releases.
    • For use of JobScheduler Long Term Support releases we encourage users to opt for a Java LTS release that provides maintenance for the same duration as JobScheduler LTS maintenance, see How long will you support the different versions of JobScheduler and YADE?
      • We strive for compatibility of JobScheduler LTS releases with newer Java LTS releases, however, we do not check compatibility with individual Java feature release.
      • We will not modify JobScheduler LTS releases to be built with newer Java versions. We will check to modify existing code to be compatible with the Java LTS release that has originally been used and with newer Java LTS releases, however, feasibility cannot be guaranteed as this depends on compatibility gaps between Java releases. 
      • For JobScheduler release 1.12 Java 1.8 is used for the build environment and  Java 1. 9,1.10, 1. 11 can be used at run-time.

...

JobScheduler ReleaseJava Runtime EnvironmentJava Build Environment
 Supported Compatibility 1)Reported Compatibility 2)Supported Compatibility 1)Reported Compatibility 2)
JobScheduler Master    
1.101.81.81.81.8
1.111.81.81.81.8
1.121.81.81.81.8
1.12.21.8, 1. 9, 1. 101.8, 1. 9, 1. 101.81.8
1.12.71.8, 1. 9, 1. 10, 1. 111.8, 1. 9, 1. 10, 1. 111.81.8
JobScheduler Agent    
1.101.81.81.81.8
1.111.81.81.81.8
1.121.81.81.81.8
1.12.3

1.8, 1. 9, 1. 10

JIRA
columnskey,summary,type,created,updated,due,assignee,reporter,priority,status,resolution
serverSOS JIRA
serverId6dc67751-9d67-34cd-985b-194a8cdc9602
keyJS-1770

1.8, 1. 9, 1. 101.81.8
1.12.71.8, 1. 9, 1. 10, 1. 111.8, 1. 9, 1. 10, 1. 111.81.8
JOC Cockpit    
1.111.81.81.81.8
1.121.81.81.81.8
1.12.21.8, 1. 9, 1. 101.8, 1. 9, 1. 101.81.8
1.12.71.8, 1. 9, 1. 10, 1. 111.8, 1. 9, 1. 10, 1. 111.81.8

 

1) Supported Compatibility: JobScheduler is tested by SOS to work with the specified Java versions, SOS provides support for operation with Java.

...